<span style=" font-size:10pt;font-family:sans-serif">> On 01/23/2018
03:13 PM, Adam Farley8 wrote:</span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> The URL
supplied by David (Holmes) lists 4.8.5 as the gcc version for</span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> building
JDK9 on SLES 11.3/12.1. Whether it's in a repository or not,</span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> I read
that as "this is the gcc version you should be building JDK9 on".</span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> </span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> </span><a href="https://urldefense.proofpoint.com/v2/url?u=https-3A__wiki.openjdk.java.net_display_Build_Supported-2BBuild-2BPlatforms&d=DwIC-g&c=jf_iaSHvJObTbx-siA1ZOg&r=P5m8KWUXJf-CeVJc0hDGD9AQ2LkcXDC0PMV9ntVw5Ho&m=63AR5zmRQCx5v-MXloqnarJvGvjLXVVnJsui6XMOMoE&s=bDVDenH2BOpYeVaU504vQiL0lqdBlELIy_wWpX44Juw&e="><span style=" font-size:10pt;color:blue;font-family:sans-serif">https://urldefense.proofpoint.com/v2/url?u=https-3A__wiki.openjdk.java.net_display_Build_Supported-2BBuild-2BPlatforms&d=DwIC-g&c=jf_iaSHvJObTbx-siA1ZOg&r=P5m8KWUXJf-CeVJc0hDGD9AQ2LkcXDC0PMV9ntVw5Ho&m=63AR5zmRQCx5v-MXloqnarJvGvjLXVVnJsui6XMOMoE&s=bDVDenH2BOpYeVaU504vQiL0lqdBlELIy_wWpX44Juw&e=</span></a>
<br><span style=" font-size:10pt;font-family:sans-serif">>> </span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> I asked
for this change to be put in 10 and 11 because I don't know the</span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> minimum/recommended
gcc version for jdk10 and 11. I'm assuming it's</span>
<br><span style=" font-size:10pt;font-family:sans-serif">>> the same
as 9 until told otherwise.</span>
<br><span style=" font-size:10pt;font-family:sans-serif">></span>
<br><span style=" font-size:10pt;font-family:sans-serif">> Building
OpenJDK-10 or OpenJDK-11 requires OpenJDK-9, so you won't be able</span>
<br><span style=" font-size:10pt;font-family:sans-serif">> to build
them in a fresh SLE-12:SP3 installation anyway.</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">I'm working on
the assumption that people will grab binaries from</span>
<br><span style=" font-size:10pt;font-family:sans-serif">AdoptOpenJDK.</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">></span>
<br><span style=" font-size:10pt;font-family:sans-serif">> SLE-11:*
doesn't even have OpenJDK-8 and is also going to be out of support</span>
<br><span style=" font-size:10pt;font-family:sans-serif">> next year
anyway.</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">Does this mean
the gcc version will change? If you have hard information on</span>
<br><span style=" font-size:10pt;font-family:sans-serif">this, I'd appreciate
the URL.</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">></span>
<br><span style=" font-size:10pt;font-family:sans-serif">> I don't necessarily
disagree bringing your changes into JDK-8 or JDK-9,</span>
<br><span style=" font-size:10pt;font-family:sans-serif">> but I don't
think they make sense to introduce them to JDK-10 and JDK-11.</span>
<br><span style=" font-size:10pt;font-family:sans-serif">></span>
<br><span style=" font-size:10pt;font-family:sans-serif">> Adrian</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">If the minimum
gcc version for 10 or 11 is above 4.8.5 across all platforms,</span>
<br><span style=" font-size:10pt;font-family:sans-serif">then I agree,
but I don't have that information, so I figured I'd ask to </span>
<br><span style=" font-size:10pt;font-family:sans-serif">cover all of the
JDK versions, to be safe. </span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">Even if the gcc
version does change, adding 4.8.5-specific code shouldn't </span>
<br><span style=" font-size:10pt;font-family:sans-serif">break anything.</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">What do you think?</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">Best Regards</span>
<br>
<br><span style=" font-size:10pt;font-family:sans-serif">Adam Farley</span>
<br><span style=" font-size:10pt;font-family:sans-serif"><br>
Unless stated otherwise above:<br>
IBM United Kingdom Limited - Registered in England and Wales with number
741598. <br>
Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6
3AU<br>
</span>