<html>
  <head>
    <meta http-equiv="Content-Type" content="text/html;
      charset=windows-1252">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    <p>Hi Pankaj,</p>
    <p>The root cause of the issue is that the underling native window
      is not yet created when its with and height are requested. This is
      because windows are created asynchronously. The test should be
      fixed by adding Robot.waitForIdle() after frame.setVisible(true).</p>
    <p>--Semyon<br>
    </p>
    <br>
    <div class="moz-cite-prefix">On 09/20/2017 05:49 AM, Pankaj Bansal
      wrote:<br>
    </div>
    <blockquote type="cite"
      cite="mid:bb4b6c2b-4457-429f-a3be-c9e44a52d38c@default">
      <meta http-equiv="Content-Type" content="text/html;
        charset=windows-1252">
      <meta name="Generator" content="Microsoft Word 15 (filtered
        medium)">
      <style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
      <div class="WordSection1">
        <p class="MsoNormal">Hi All,<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">Please review the fix for test program test
          java/awt/Component/PrintAllXcheckJNI/PrintAllXcheckJNI.java
          for JDK 10.<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">Bug:<o:p></o:p></p>
        <p class="MsoNormal"><a
            href="https://bugs.openjdk.java.net/browse/JDK-6857809"
            moz-do-not-send="true">https://bugs.openjdk.java.net/browse/JDK-6857809</a><o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">Webrev:<o:p></o:p></p>
        <p class="MsoNormal"><span style="color:#1F497D"><a
              href="http://cr.openjdk.java.net/%7Eaghaisas/pankaj/6857809/webrev.0/"
              moz-do-not-send="true">http://cr.openjdk.java.net/~aghaisas/pankaj/6857809/webrev.0/</a><o:p></o:p></span></p>
        <p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
        <p class="MsoNormal">Issue:<o:p></o:p></p>
        <p class="MsoNormal">The test
           java/awt/Component/PrintAllXcheckJNI/PrintAllXcheckJNI.java
          fails on Linux intermittently due to
          “java.lang.IllegalArgumentException: Width (0) and height (0)
          cannot be <= 0” exception.<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">Fix:<o:p></o:p></p>
        <p class="MsoNormal">Made changes in
          java/awt/Component/PrintAllXcheckJNI/PrintAllXcheckJNI.java to
          set the size of frame to make the test more stable.<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">Regards,<o:p></o:p></p>
        <p class="MsoNormal">Pankaj Bansal<o:p></o:p></p>
      </div>
    </blockquote>
    <br>
  </body>
</html>