[patch] Building with Xcode 5 on OS X 10.9

Jürgen Kreileder jk at blackdown.de
Fri Nov 1 10:44:41 PDT 2013


Hi,

the appended changesets for build and hotspot allow building with "USE_CLANG=true make" on OS X 10.9 using Xcode 5.0.1.


        Juergen

# HG changeset patch
# User Jürgen Kreileder <jk at blackdown.de>
# Date 1383086029 -3600
# Node ID 5cf40fd518ba9df9ef1806e9c2d6ace3ebc5366c
# Parent  4f2011496393a26dcfd7b1f7787a3673ddd32599
Allow building with "USE_CLANG=true make" on OS X Mavericks with Xcode 5.0.1

diff --git a/common/autoconf/generated-configure.sh b/common/autoconf/generated-configure.sh
--- a/common/autoconf/generated-configure.sh
+++ b/common/autoconf/generated-configure.sh
@@ -3865,7 +3865,7 @@
 #CUSTOM_AUTOCONF_INCLUDE
 
 # Do not change or remove the following line, it is needed for consistency checks:
-DATE_WHEN_GENERATED=1382702260
+DATE_WHEN_GENERATED=1383085981
 
 ###############################################################################
 #
@@ -20069,11 +20069,15 @@
     # Check that this is likely to be GCC.
     $COMPILER --version 2>&1 | $GREP "Free Software Foundation" > /dev/null
     if test $? -ne 0; then
-      { $as_echo "$as_me:${as_lineno-$LINENO}: The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler." >&5
+      COMPILER_VERSION_TEST=`$COMPILER --version 2>&1 | $HEAD -n 2 | $TAIL -n 1 `
+      $COMPILER --version 2>&1 | $GREP "Apple LLVM" > /dev/null
+      if test $? -ne 0; then
+        { $as_echo "$as_me:${as_lineno-$LINENO}: The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler." >&5
 $as_echo "$as_me: The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler." >&6;}
-      { $as_echo "$as_me:${as_lineno-$LINENO}: The result from running with --version was: \"$COMPILER_VERSION_TEST\"" >&5
+        { $as_echo "$as_me:${as_lineno-$LINENO}: The result from running with --version was: \"$COMPILER_VERSION_TEST\"" >&5
 $as_echo "$as_me: The result from running with --version was: \"$COMPILER_VERSION_TEST\"" >&6;}
-      as_fn_error $? "GCC compiler is required. Try setting --with-tools-dir." "$LINENO" 5
+        as_fn_error $? "GCC compiler is required. Try setting --with-tools-dir." "$LINENO" 5
+      fi
     fi
 
     # First line typically looks something like:
@@ -21648,11 +21652,15 @@
     # Check that this is likely to be GCC.
     $COMPILER --version 2>&1 | $GREP "Free Software Foundation" > /dev/null
     if test $? -ne 0; then
-      { $as_echo "$as_me:${as_lineno-$LINENO}: The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler." >&5
+      COMPILER_VERSION_TEST=`$COMPILER --version 2>&1 | $HEAD -n 2 | $TAIL -n 1 `
+      $COMPILER --version 2>&1 | $GREP "Apple LLVM" > /dev/null
+      if test $? -ne 0; then
+        { $as_echo "$as_me:${as_lineno-$LINENO}: The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler." >&5
 $as_echo "$as_me: The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler." >&6;}
-      { $as_echo "$as_me:${as_lineno-$LINENO}: The result from running with --version was: \"$COMPILER_VERSION_TEST\"" >&5
+        { $as_echo "$as_me:${as_lineno-$LINENO}: The result from running with --version was: \"$COMPILER_VERSION_TEST\"" >&5
 $as_echo "$as_me: The result from running with --version was: \"$COMPILER_VERSION_TEST\"" >&6;}
-      as_fn_error $? "GCC compiler is required. Try setting --with-tools-dir." "$LINENO" 5
+        as_fn_error $? "GCC compiler is required. Try setting --with-tools-dir." "$LINENO" 5
+      fi
     fi
 
     # First line typically looks something like:
diff --git a/common/autoconf/toolchain.m4 b/common/autoconf/toolchain.m4
--- a/common/autoconf/toolchain.m4
+++ b/common/autoconf/toolchain.m4
@@ -65,9 +65,13 @@
     # Check that this is likely to be GCC.
     $COMPILER --version 2>&1 | $GREP "Free Software Foundation" > /dev/null
     if test $? -ne 0; then
-      AC_MSG_NOTICE([The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler.])
-      AC_MSG_NOTICE([The result from running with --version was: "$COMPILER_VERSION_TEST"])
-      AC_MSG_ERROR([GCC compiler is required. Try setting --with-tools-dir.])
+      COMPILER_VERSION_TEST=`$COMPILER --version 2>&1 | $HEAD -n 2 | $TAIL -n 1 `
+      $COMPILER --version 2>&1 | $GREP "Apple LLVM" > /dev/null
+      if test $? -ne 0; then
+        AC_MSG_NOTICE([The $COMPILER_NAME compiler (located as $COMPILER) does not seem to be the required GCC compiler.])
+        AC_MSG_NOTICE([The result from running with --version was: "$COMPILER_VERSION_TEST"])
+        AC_MSG_ERROR([GCC compiler is required. Try setting --with-tools-dir.])
+      fi
     fi
 
     # First line typically looks something like:
=
# HG changeset patch
# User Jürgen Kreileder <jk at blackdown.de>
# Date 1383086084 -3600
# Node ID d02d1e0b9c8deeaa9e1bc59b723aef6de593e7fd
# Parent  7fd913010dbbf75260688fd2fa8964763fa49a09
Allow building with "USE_CLANG=true make" on OS X Mavericks with Xcode 5.0.1

diff --git a/make/bsd/makefiles/gcc.make b/make/bsd/makefiles/gcc.make
--- a/make/bsd/makefiles/gcc.make
+++ b/make/bsd/makefiles/gcc.make
@@ -325,6 +325,13 @@
   endif
 endif
 
+# Use libstdc++
+ifeq ($(USE_CLANG), true)
+  ifeq ($(shell expr $(CC_VER_MAJOR) \> 4), 1)
+    LFLAGS += -stdlib=libstdc++
+  endif
+endif
+
 # Flags for generating make dependency flags.
 DEPFLAGS = -MMD -MP -MF $(DEP_DIR)/$(@:%=%.d)
 ifeq ($(USE_CLANG),)
=


-- 
https://blackdown.de/


More information about the build-dev mailing list