PROPOSAL: checked exception handling enhancement
evildeathmath at yahoo.com
Tue Mar 31 06:05:52 PDT 2009
I suggest then replacing "wtf" with "wtf!?", which should be safe as it would currently generate a compiler error in all suggested contexts and is not a valid identifier name.
--- On Mon, 3/30/09, Joseph D. Darcy <Joe.Darcy at Sun.COM> wrote:
From: Joseph D. Darcy <Joe.Darcy at Sun.COM>
Subject: Re: PROPOSAL: checked exception handling enhancement
To: evildeathmath at yahoo.com
Cc: coin-dev at openjdk.java.net
Date: Monday, March 30, 2009, 7:08 PM
evildeathmath at yahoo.com wrote:
> Eugene Ray
> FEATURE SUMMARY:
> A new class-level modifier keyword, "wtf", is added to the language, eliminating the need to explicitly handle every checked exception in the class.
I think the wide possible use of the name in question must disqualify
the proposal from consideration.
More information about the coin-dev