Hmm... Suppressed Exceptions are Throwables[]

Joe Darcy joe.darcy at
Fri Nov 12 01:12:41 PST 2010

Joe Darcy wrote:
> Osvaldo Pinali Doederlein wrote:
>>   My $0.02:  getSupressed().
> Hopefully the method name would not be misinterpreted as a command!
>> - It's sufficiently clear (from both the context of the containing 
>> class and the return static type), so this is terse without being 
>> obscure;
>> - There is a BIG precedent: we already have getCause(), not 
>> getCauseException() or getCauseThrowable().
> Good point; I'll consider this renaming.

FYI, this method renaming along with some other changes to Throwable is 
out for review on core-libs-dev:


More information about the coin-dev mailing list