Documentation of Project Coin features as implemented in the JDK 7 developer preview

Ulf Zibis Ulf.Zibis at
Wed Mar 9 12:23:06 PST 2011

Am 09.03.2011 18:37, schrieb Joe Darcy:
> Hello.
> As noted in subsequent discussion, the "diamond operator" isn't really an operator and we have 
> taken to not referring to it as such.  For consistency, I think it is fine to allow (but 
> discourage) extra white space between the "<" and ">" characters of a diamond.  I find this 
> similar to the allowable white space between  the "@" and type name of an annotation.
> Cheers,
> -Joe

Surprised about the lifely discussion (about the color of the bike shed). :-o

To be consequent, we should rename the construct to "empty type list" and forget all about diamond 

Otherwise, what about "bubble" for "( )" ? ;-)


More information about the coin-dev mailing list