Review request for 6810254 (v01)
Alan.Bateman at Sun.COM
Wed Mar 11 20:01:36 UTC 2009
Mandy Chung wrote:
> David, Alan,
> Thanks for your feedback. I revise the fix per Alan's suggestion. I
> decide not to keep the fix to lazily initialize the shutdown hook
> only. So java.io.Console, DeleteOnExitHook and
> java.lang.ApplicationShutdownHooks are only loaded when the app uses it.
> Webrev at:
This looks a lot better. One suggestion is to reverse the order of the
parameters to registerShutdownHook so that the Runnable is last. That
would make it easier to read and also easier to see the hook slot which
is the fragile part to the solution.
Minor nit is that the comment in Shutdown.java reads "The order in with
the hooks are added here is important ...". The registration order
doesn't matter now so this could be changed.
More information about the core-libs-dev