Adding constant for line.separator and friends
Ulf.Zibis at gmx.de
Wed Nov 11 22:57:54 UTC 2009
Am 11.11.2009 22:48, Martin Buchholz schrieb:
> On Wed, Nov 11, 2009 at 12:46, Stephen Colebourne
> <scolebourne at joda.org <mailto:scolebourne at joda.org>> wrote:
> Martin Buchholz wrote:
> On Wed, Nov 11, 2009 at 10:10, Ulf Zibis <Ulf.Zibis at gmx.de
> <mailto:Ulf.Zibis at gmx.de> <mailto:Ulf.Zibis at gmx.de
> <mailto:Ulf.Zibis at gmx.de>>> wrote:
> At least, IMO, fileSeparator() and pathSeparator() would
> belong to
> java.io.File or java.nio.file.FileSystem.
> Those would have been better names,
> but at this point they are not worth adding.
> I don't follow - why are they not worth adding now?
> Because java.io.File already provides the functionality users need.
> Not in the best way - as fields instead of methods, and
> only the first char of the system property. But it's not broken enough
> to be worth fixing by providing a slightly better API.
Sorry for not have checked that (misleaded by request from
Weijun.Wang at Sun.COM 46 hours ago)
> IMO, of course.
> Becuase they should have been in JDK 1.0? Because JDK 7 is about
> to release? Some other reason? How and who is deciding?
> it's a hard problem, and one that Sun/JCP/OpenJDK still needs to address.
I know this problem, see:
https://bugs.openjdk.java.net/show_bug.cgi?id=100091, 100092, 100095,
100098, 1000104, 1000105, 1000107 and plenty patches from others.
Most of them not even just have sponsors :-(
Seems to be work for garbage. Only few externals have chance for
contribution, mostly ex-employees from Sun.
> I guess right now folks are waiting for the Oracle acquisition.
More information about the core-libs-dev