Sponsoring getting 5015163 "(str) String merge/join that is the inverse of String.split()" into JDK 7
David.Holmes at Sun.COM
Mon Oct 26 09:29:32 PDT 2009
Joseph D. Darcy wrote:
> Stephen Colebourne wrote:
>> Joe, would you be prepared to sponsor a Strings class, and see join on
>> there instead of String?
It was necessary to introduce Arrays and Collections for utility methods
because there was no place else to locate the static methods. But for String
these should simply be static String methods.
But that also means I'd prefer to see additional static methods in Object,
rather than the added Objects class.
Personally I think a java.util.Utilities class containing nested static
classes for Objects, Arrays, Collections, Strings, Maps etc, might have been
a better way to organize such things. But it's probably too late now as the
duplication would be very ugly.
More information about the core-libs-dev