Review Request for 6878481: Add performance counters in the JDK
Alan.Bateman at Sun.COM
Sun Sep 13 01:07:15 PDT 2009
Mandy Chung wrote:
> Alan, David, Remi, Iris,
> Thanks for the review and the revised webrev at:
> I incorporate the comments you have and minimize the number of
> System.nanoTime() calls and also remove the number of opened jars perf
> counters. Please let me know if you have further comments.
This looks much better, in particular the overhead in ClassLoader is
much reduced. Also, I see you've removed the special counter for JAR
files, which make sense.
Minor nit but I assume you can initialize perf as:
private static final Perf perf =
Also minor nit: in the javadoc of the PerfCounter's public methods - I
assume you meant to use /** instead of /*.
Method naming is hard (and often subjective) but there are updates like
PerfCounter.getParentDelegationTime.inc(t1 - t0);
which might be easier to read as:
PerfCounter.getParentDelegationCounter().addTime(t1 - t0)
which might be cleaer as:
Just a suggestion of course. Otherwise, looks okay to me and I'm looking
forward to seeing the output once these changes are in.
More information about the core-libs-dev