Code review request for 6998871 "Support making the Throwable.stackTrace field immutable"
dmytro_sheyko at hotmail.com
Thu Apr 7 11:27:03 UTC 2011
Thanks. Got it.
> Date: Thu, 7 Apr 2011 18:03:42 +1000
> From: David.Holmes at oracle.com
> To: dmytro_sheyko at hotmail.com
> CC: joe.darcy at oracle.com; core-libs-dev at openjdk.java.net
> Subject: Re: Code review request for 6998871 "Support making the Throwable.stackTrace field immutable"
> Dmytro Sheyko said the following on 04/07/11 17:50:
> > Just wonder what is the purpose of dummy parameter in native fillInStackTrace method. Couldn't we simply rename it (e.g. to fillInStackTrace0)
> Using an overload instead of renaming the native method was initially
> done to avoid having to make changes to the stacktrace filtering code in
> the VM. It turns out that we need to make a change anyway, but it is
> easier if we stick with the one name for the method to be filtered out.
> This isn't set in concrete though.
More information about the core-libs-dev