JDK 8 code review request for 7062430 "Minor iconsistency in ulp descriptions"
Alan.Bateman at oracle.com
Sat Jul 16 06:21:55 UTC 2011
Joe Darcy wrote:
> Please review this small doc change to spell out what "ulp" means in
> the methods named "ulp" in the Math and StrictMath classes; patch
> below, webrev at:
> 7062430 "Minor iconsistency in ulp descriptions"
> Due to paragraph reformatting, the change takes up many more physical
> lines than logical ones. In each of the four ulp methods (for for
> float and one for double in each of Math and StrictMath) the phrase
> "An ulp of a [...] value is the positive distance..."
> is replaced with
> "An ulp, unit in the last place, of a [...] value is the positive
> Additionally, the reference to ulp in one the opening paragraphs of
> the Math class description is replaced with a link to one of the ulp
> methods in Math.
This looks fine to me too.
More information about the core-libs-dev