RFR: 8004699 : Add type annotation storage to Constructor, Field and Method
joel.franck at oracle.com
Mon Dec 17 16:51:54 UTC 2012
On Dec 17, 2012, at 4:47 PM, Alan Bateman <Alan.Bateman at oracle.com> wrote:
> On 17/12/2012 15:41, Joel Borggrén-Franck wrote:
>> Here is the first in a series of changes to add type annotation support to reflection.
> I assume this should be typeAnnotations rather than type_annotations so that it's consistent with the existing fields.
Doh. However since these fields are not the permanent solution and the overhead to changing naming is large, I would (vert strongly) prefer to keep the (bad) HotSpot naming convention for now.
> Have the Hotspot changes been pushed already?
Out for review here: http://mail.openjdk.java.net/pipermail/hotspot-dev/2012-December/007637.html
More information about the core-libs-dev