RFR: 8004699 : Add type annotation storage to Constructor, Field and Method
Alan.Bateman at oracle.com
Tue Dec 18 09:52:05 UTC 2012
On 17/12/2012 16:51, Joel Borggrén-Franck wrote:
> On Dec 17, 2012, at 4:47 PM, Alan Bateman<Alan.Bateman at oracle.com> wrote:
>> On 17/12/2012 15:41, Joel Borggrén-Franck wrote:
>>> Here is the first in a series of changes to add type annotation support to reflection.
>> I assume this should be typeAnnotations rather than type_annotations so that it's consistent with the existing fields.
> Doh. However since these fields are not the permanent solution and the overhead to changing naming is large, I would (vert strongly) prefer to keep the (bad) HotSpot naming convention for now.
As the hotspot changes are still in review then I think it would be best
to just rename the fields now, even if its not the final solution.
More information about the core-libs-dev