Review request:Updated JDK-8004728 Implement core reflection API for parameter reflection

Jeff Hain jeffhain at
Sat Dec 22 16:40:57 UTC 2012

Rémi wrote:
>getNumParameters (I prefer the name getParameterCount() BTW)

I prefer getParameterCount() too.

When something has "nb", "num", "nbr" or "number" in its name,
people might get wrong about whether it refers to a count
(n sheeps) or to an identifier (sheep number n).

If "count" or "id"-likes can't be used instead, and one has to
stick with "number"-likes, one rule could be to use "nbr" for
counts and "num" for ids: both have the same size (handy for
code alignment), and they respectively match with french
"nombre" and "numéro", which have the appropriate meanings.


More information about the core-libs-dev mailing list