RFR: 8023528: Rename Comparator combinators to disambiguate overloading methods

Stuart Marks stuart.marks at oracle.com
Fri Aug 23 06:00:21 UTC 2013

Hi Henry,

Changes look good. It's also good to see some now-extra casts and type 
witnesses removed. It somewhat makes up for the longer, non-overloaded 
method names.

Note, corrected email thread[2] link:



On 8/22/13 8:21 PM, Henry Jen wrote:
> Hi,
> Please review a relative simple webrev[1] that basically simply renaming
> Comparator methods. The reason behind the renaming can be found at this
> email thread[2]. The specdiff is also available here[3].
> Cheers,
> Henry
> [1] http://cr.openjdk.java.net/~henryjen/ccc/8023528/0/webrev/
> [2]
> http://mail.openjdk.java.net/pipermail/lambda-libs-spec-expert/2013-August/002206.html
> [3]
> http://cr.openjdk.java.net/~henryjen/ccc/8023528/0/specdiff/overview-summary.html

More information about the core-libs-dev mailing list