Fwd: RFR: 8007806: Need a Throwables performance counter
Alan.Bateman at oracle.com
Fri Feb 22 13:44:01 UTC 2013
On 22/02/2013 13:10, Nils Loodin wrote:
> Does anyone have anything strongly against this? This is a small
> change just to add a performance counter, the code to increment it and
> read it will live in other parts of the code and be a part of a larger
> separate commit.
> Alan Bateman gave the response that the name was inappropriate, but I
> don't really have a better alternative, but neither do I have strong
> opinions, so feedback would be appreciated!
> How about
> "sun.throwables.thrownThrowables" ?
My comment on the counter name was mostly that sun.misc.PerfCounter
isn't really the right place to create a hotspot.* counters. Using the
eixsting sun.* or start a new jdk.* name space seems more appropriate. I
don't have a strong opinion on the name.
More information about the core-libs-dev