RFR 8009736: Comparator API cleanup

Henry Jen henry.jen at oracle.com
Sat Jun 15 23:27:09 UTC 2013

On 06/14/2013 10:10 AM, Jason Mehrens wrote:
> Any chance the static method Comparator.reverseOrder()  will be renamed
> to something like reversedNaturalOrder?  Now all of the calls to
> Comparator.reverseOrder() take on new meaning.

I feel that it's inconvenient for early adapters, but this is still the
new API in 8 and we should still choose the best name.

reverseOrder() is a natural choice and just a migration from Comparators.

The old reverseOrder() is an instance default method, and is a
compromise of reverse() for name clashing, I think reversed() is the
right name.

As the renaming of that default method is necessary, I think it's just
need more attention on find out all method calls. The difference between
a static and default method can be used to hint on search in files.


More information about the core-libs-dev mailing list