RFR: 8009428 and 8009429 - Profile related fixes and clean ups
david.holmes at oracle.com
Fri Mar 8 11:34:57 UTC 2013
On 8/03/2013 9:25 PM, Erik Joelsson wrote:
> On 2013-03-08 10:19, Alan Bateman wrote:
>> On 08/03/2013 01:48, David Holmes wrote:
>>> Not sure which is best list for this given Alan will likely be the
>>> only reviewer anyway :)
>>> Webrevs under:
>> As further background to others, the reverting of the $ substitution
>> became possible when Nashorn removed $ from its generated classes .
>> I've looked through the changes and they look really good to me.
>> Putting $< in single quotes to avoid shell expansion is the solution
>> that I could not find when adding the de-beaning recipes a few months
>> ago. It's great to see PROFILE_4 renamed to FULL_JRE and is also great
>> to remove the redundant sub-packages from the include lists. For
>> profiles-rtjar-includes then I think it makes it much more readable
>> and maintainable. Two minor inconsistencies: the sub-packages of
>> javax.naming are listed and com/sun/jndi/ has a trailing slash.
>> One probable side effect of removing the redundant sub-packages will
>> be the javadoc. The one case to date where we didn't list sub-packages
>> is java.time (because there are still changes going on there) and that
>> the result is that the sub-packages of java.time don't show up in the
>> profiles view. I created 8008367 a few weeks for that and I suspect
>> that once these changes are pushed that the profiles view will be very
>> incomplete. I don't think this should be a reason to hold off your
>> changes as the profiles view isn't right now anyway. Hopefully Bhavesh
>> will get to this soon.
>> I think Erik should review this too as it's important that the build
>> changes in jdk8/tl will merge easily with changes going into jdk8/build.
>>  http://hg.openjdk.java.net/jdk8/tl/nashorn/rev/fe5211fc3114
> Looks good to me and thanks again for cleaning up that $ business. I do
> not think this will conflict with anything coming from jdk8/build.
More information about the core-libs-dev