RFR : 8013712 : (XS) Add Objects.nonNull and Objects.isNull

Jeff Hain jeffhain at rocketmail.com
Thu May 2 11:14:06 UTC 2013


nonNull could be renamed into isNonNull,
else people might use it instead of requireNonNull,
especially if they are already used to a pre-Java 7
requireNonNull that would be called nonNull.

It would also be more consistent with isNull.


More information about the core-libs-dev mailing list