RFR : 8013712 : (XS) Add Objects.nonNull and Objects.isNull
Ulf.Zibis at CoSoCo.de
Sat May 4 15:09:53 UTC 2013
Am 04.05.2013 04:28, schrieb Mike Duigou:
> I have updated the webrev to include incorporate the feedback I have received.
> Regarding the naming of the "nonNull" method. I originally added this method in 2011 but I've forgotten since then why it has the name it does. As best as I can determine the name is either derived from the the name used by Guava for the same predicate, "notNull", or the names derives from the name "requireNonNull" in that this method doesn't require that the reference be non-null. The EG hasn't been concerned that this method doesn't use the "is" prefix.
Do we need nonNull/isNotNull() at all, as it's always !isNull()?
Anyway I would prefer isNotNull().
More information about the core-libs-dev