Add getChars to CharSequence

Martin Buchholz martinrb at
Wed May 8 22:05:22 UTC 2013

Alan (et al): Ping.

On Wed, May 1, 2013 at 3:19 PM, Martin Buchholz <martinrb at> wrote:

> Another version of this change is ready.  No longer preliminary.  Tests
> have been written.
> This kind of change is particularly subject to feature creep, and I am
> trying to restrain myself.
> I even addressed some of Ulf's suggestions.
> The "Msg" suffix  is gone.
> I reverted changes to AbstractStringBuilder.replace.
> I kept the naming convention for getChars parameter names.
> Parameter names and exception details continue to be maddeningly
> unsystematic, but they should be a little better than before.

More information about the core-libs-dev mailing list