RFR(S): JDK-8033911 Simplify instrumentation of FileInputStream and RandomAccessFile
dmitry.samersoff at oracle.com
Fri Feb 7 11:30:23 UTC 2014
OK! Looks good for me.
On 2014-02-07 15:28, Staffan Larsen wrote:
> I would prefer that to be a different change.
> On 7 feb 2014, at 12:07, Dmitry Samersoff <dmitry.samersoff at oracle.com> wrote:
>> As far as you touching this.
>> Is it possible to change all native methods in these two classes to have
>> 0 at the end of name?
>> i.e. readBytes => readBytes0
>> it's pure cosmetic, but fairly simplify core dump reading and later
>> On 2014-02-07 14:46, Staffan Larsen wrote:
>>> A few of the public read and write methods in FileInputStream and RandomAccessFile are declared native. This means that it is hard to instrument them using byte code instrumentation. Changing the public methods to be to non-native and instead calling private native methods simplifies instrumentation.
>>> webrev: http://cr.openjdk.java.net/~sla/8033911/webrev.00/
>>> bug: https://bugs.openjdk.java.net/browse/JDK-8033911
>> Dmitry Samersoff
>> Oracle Java development team, Saint Petersburg, Russia
>> * I would love to change the world, but they won't give me the sources.
Oracle Java development team, Saint Petersburg, Russia
* I would love to change the world, but they won't give me the sources.
More information about the core-libs-dev