RFR 9: 8003488 Add Process.getPid
Alan.Bateman at oracle.com
Thu May 22 15:44:48 UTC 2014
On 22/05/2014 16:34, David M. Lloyd wrote:
> I guess this is a little late, and minor, but the "jstack" tool uses
> the acronym "nid" for this purpose, which I believe is mapped to the
> same concept (on Linux it is anyway).
> I think either this terminology should be unified on the jstack side,
> or else the method should be called "getNativeId" or "getNid" or
Are you thinking of "vmid" by any chance? If so then that term comes
from jvmstat. It uses String for the identifier because it can support
inspecting the counters of remote VMs (pid at host for example). If I
recall correctly then jstack allows for a String too, mostly because it
has its roots as a SA tool where it can connect to a remote VM when
jsadebugd is running.
More information about the core-libs-dev