RFR: 5108778 Too many instances of java.lang.Boolean created in Java application(core-libs)

Sebastian Sickelmann sebastian.sickelmann at gmx.de
Sun Nov 8 12:50:10 UTC 2015


i wanted to start a discussion/review-process some time ago, see the
second-try below.

Is there someone who wants to discuss/review/sponsor these changes?

Else, should i link my result as reference into the JBS?

For the two other affected mailing-lists/repos
(macos-port-dev[0],net-dev[1]) i created a subtask for each. If this
three patches here cannot go into one review, i would create subtasks
for those as well, to handle the different state of theses changes .

-- Sebastian

[1] http://mail.openjdk.java.net/pipermail/net-dev/2015-November/009308.html

On 10/27/2015 05:32 AM, Sebastian Sickelmann wrote:
> Hello,
> Actually I am searching through the JBS for low hanging fruits.
> Right now i am looking through the openjdk-sources and try to evaluate
> if i can make something about JDK-5108778.
> Please find my webrevs for the jaxp, jaxws and corba repos at:
> http://cr.openjdk.java.net/~sebastian/5108778/jaxp/webrev.00/
> http://cr.openjdk.java.net/~sebastian/5108778/jaxws/webrev.00/
> http://cr.openjdk.java.net/~sebastian/5108778/corba/webrev.00/
> I hope for jaxp,jaxws and corba this mailinglist is also the right place.
> jaxp:
> For the change in XBoolean (jaxp) i thought it would be more readable
> than the autoboxing solution.
> jaxws:
> The changes in jaxws are in a generated class. I would love to fix this
> in the source, but i have no clue where the real source could be.
> corba:
> For all calls against
> com.sun.tools.corba.se.idl.constExpr.Expression.value(Object) i used the
> valueOf solution instead of the autoboxing for better readability.
> -- Sebastian

More information about the core-libs-dev mailing list