Proposed API for JEP 259: Stack-Walking API
mandy.chung at oracle.com
Fri Oct 30 22:35:02 UTC 2015
> On Oct 30, 2015, at 1:26 PM, Remi Forax <forax at univ-mlv.fr> wrote:
> In StackWalker.Option,
> i think that CLASS_REFERENCE can be renamed to KEEP_CLASS_REFERENCE, maybe ?
What about RETAIN_CLASS_REFERENCE?
I have updated the javadoc in place:
- CLASS_REFERENCE renamed to RETAIN_CLASS_REFERENCE
- remove StackWalker.WalkerOption interface
- the batchSizeMapper argument is of IntUnaryOperator type.
Thanks for the feedback, Remi and David.
More information about the core-libs-dev