RFR(S): 8154751: MethodHandles.countedLoop does not accept empty bodies

Claes Redestad claes.redestad at oracle.com
Fri Apr 22 10:09:42 UTC 2016

Hi Michael,

voidReturn ? zero(void.class) : identity(init.type().returnType()) is 
used twice, breaking it out to variable would improve readability, 
possibly performance. Same goes for the subexpression 
init.type().returnType() which is used three times currently.

Otherwise it looks fine to me.



On 2016-04-20 15:13, Michael Haupt wrote:
> Dear all,
> please review this change.
> Bug: https://bugs.openjdk.java.net/browse/JDK-8154751
> Webrev: http://cr.openjdk.java.net/~mhaupt/8154751/webrev.00/
> Thanks,
> Michael

More information about the core-libs-dev mailing list