RFR(m): 8140281 deprecate Optional.get()
vitalyd at gmail.com
Wed Apr 27 11:20:38 UTC 2016
On Wednesday, April 27, 2016, Andrew Haley <aph at redhat.com> wrote:
> On 27/04/16 11:51, Vitaly Davidovich wrote:
> > On Wednesday, April 27, 2016, Andrew Haley <aph at redhat.com
> >> On 27/04/16 00:38, Vitaly Davidovich wrote:
> >>> I've yet to hear one supporter on this thread besides yourself and
> >> Stuart.
> >> Do you really want to turn this discussion into even more of a
> >> bikeshed discussion?
> > Not at all. Simply saying I find this proposal odd, and I didn't get the
> > feeling I'm alone by reading the other responses here.
> You're not alone, but not everyone should chime in. Now that I'm
> here I have to say that deprecating bad names is an excellent
> thing to do, and what enhanced deprecation should be doing.
Sure, but there's no agreement it's a bad name to begin with. It's a fine
name, with precedent, and avoids visual noise when used as
intended. Optional has something like a dozen methods with very simple
javadoc - if a developer misused it, they'll learn and move on. There's
really no issue here at all, as far as I'm concerned. I understand Brian
and Stuart's thinking, but it's not addressing any real issue, IMO.
Sent from my phone
More information about the core-libs-dev