RFR(m): 8140281 deprecate Optional.get()

Maurizio Cimadamore maurizio.cimadamore at oracle.com
Wed Apr 27 17:43:26 UTC 2016

On 27/04/16 09:31, Andrew Haley wrote:
> what they say makes
> sense to me
It makes sense to me to. Having an innocently-named get() method 
throwing an exception is not something you see everyday. And in this 
case it's doubly confusing because one could imagine also a different 
behavior (i.e. return null if no object is there). So I'm in favor for 
making things clearer by choosing a more explicit name (whether the 
proposed one or a better one).


More information about the core-libs-dev mailing list