RFR(S): 8150825: MethodHandles.tryFinally throws IndexOutOfBoundsException for non-conforming parameter lists
paul.sandoz at oracle.com
Mon Feb 29 13:16:49 UTC 2016
> On 29 Feb 2016, at 13:59, Claes Redestad <claes.redestad at oracle.com> wrote:
> Looks good to me!
> (Slightly off-topic: would it be possible to rename the test to something more descriptive, or is such things frowned upon?)
I support renaming too. Using the initial integration bug id for a test is likely to become confusing and less relevant over time (e.g. as new issues are added to the test itself).
The test name is important as it flows through the whole test process and when i see “…/invoke/T8139885.java failed” i don’t know really known what that means. If i saw “…/invoke/TryFinallyCombinatorTest.java failed” then i would have more of a clue :-)
My suggestion, as a follow on issue, is to split the test out into separate areas of high-level functionality and each test named according to that functionality.
More information about the core-libs-dev