Roger.Riggs at Oracle.com
Fri Apr 7 14:45:38 UTC 2017
That's an unfortunate artifact of evolution.
Process.getPid() was added early in 2014 and ProcessHandle a year later.
Several iterations of ProcessHandle API explored Process being a
subclass of ProcessHandle
so the method names would be the same. When ProcessHandle was decoupled
the method name was retained for consistency.
On 4/7/2017 10:29 AM, mark.reinhold at oracle.com wrote:
> Playing around with the `ProcessHandle` API the other day, I noticed
> that it uses non-Beans accessor names (good!) -- except for `getPid()`.
> Is there a reason why that method isn't just `pid()`?
> - Mark
More information about the core-libs-dev