RFR(s) #2: 6344935: (spec) clarify specifications for Object.wait overloads
martinrb at google.com
Mon Aug 21 04:07:31 UTC 2017
On Sun, Aug 20, 2017 at 6:36 PM, David Holmes <david.holmes at oracle.com>
> On 20/08/2017 6:37 AM, Martin Buchholz wrote:
>> Future projects:
>> 377 * <li>The specified amount of real time has elapsed, more or less.
>> Replace with
>> * <li>At least the specified amount of real time has elapsed.
>> (I think I failed to persuade David last time ...)
> And you will continue to do so. :) In the presence of spurious wakeups it
> is completely untestable to say "at least the specified time has elapsed"
My view is that spurious wakeup is a separate item in this list. "The
specified amount of real time has elapsed" should only be about "normal"
377 * <li>The specified amount of real time has elapsed, more or less....
382 * <li>Thread <var>T</var> is awakened spuriously. (See below.)
I feel that "returning early" should occur only for rare spurious wakeups
(and I'd like even those to go away someday).
More information about the core-libs-dev