RFR 4358774: Add null InputStream and OutputStream

Brian Burkhalter brian.burkhalter at oracle.com
Wed Dec 6 19:28:10 UTC 2017

The name “emptyStream()” was considered for InputStream and “discardingStream()” for OutputStream. It was thought that “null” or “empty” would be more likely to be found by developers due to familiarity. FWIW there is precedent in third party libraries for the “null” names.


On Dec 6, 2017, at 11:11 AM, Jonathan Gibbons <jonathan.gibbons at oracle.com> wrote:

> "null" is a significant term in the Java ecosystem, and the relationship here, to /dev/null or NUL seems somewhat tenuous.
> Have any other names been considered?  At least for the InputStream, calling it an "empty stream" seems more intuitive than a "null stream".

More information about the core-libs-dev mailing list