RFR 4358774: Add null InputStream and OutputStream
brian.burkhalter at oracle.com
Thu Dec 7 19:27:49 UTC 2017
On Dec 7, 2017, at 6:08 AM, Alan Bateman <Alan.Bateman at oracle.com> wrote:
> If nothing else, a private ensureOpen method would make it easier to read so that the "if (closed) throw ..." isn't needed in every method.
On Dec 6, 2017, at 7:03 PM, Vitaly Davidovich <vitalyd at gmail.com> wrote:
> From a performance angle, I'd be more concerned with the calls to Objects.xyz() methods there. Unless something has changed in the JIT recently, those are susceptible to profile pollution and can cause missed optimizations. I'd inline those methods manually to give these methods their own profiles.
More information about the core-libs-dev