RFR of 8180451: ByteArrayInputStream should override readAllBytes, readNBytes, and transferTo

Brent Christian brent.christian at oracle.com
Tue Dec 12 20:23:51 UTC 2017

Hi, Brian

The changes look fine to me.
I would have found the test case a little easier to follow if 
"off"/"len" weren't named so similarly to "offset"/"length", but it's 
not a big deal.


On 12/11/17 12:47 PM, Brian Burkhalter wrote:
> https://bugs.openjdk.java.net/browse/JDK-8180451
> http://cr.openjdk.java.net/~bpb/8180451/webrev.00
> 1. Add overrides of readAllBytes(), readNBytes(), and transferTo().
> 2. Simplify parameter checks in read(byte[],int,int).
> 3. Change <code>foo</code> to {@code foo}.
> Thanks,
> Brian

More information about the core-libs-dev mailing list