RFR 10 JDK-8159995: Rename internal Unsafe.compare methods
ron.pressler at oracle.com
Fri May 5 19:27:29 UTC 2017
Please review the following core/hotspot change:
This change is covered by existing tests.
The following renaming was applied:
- compareAndExchange*Volatile -> compareAndExchange*
- compareAndSwap* -> compareAndSet*
- weakCompareAndSwap* -> weakCompareAndSet*Plain
- weakCompareAndSwap*Volatile -> weakCompareAndSet*
At this stage, only method and hotspot intrinsic names were changed;
node names were left as-is, and may be handled in a separate issue.
More information about the core-libs-dev