JDK-8067661: transferTo proposal for Appendable
brian.burkhalter at oracle.com
Tue Nov 14 15:33:00 UTC 2017
On Nov 14, 2017, at 3:45 AM, Alan Bateman <Alan.Bateman at oracle.com> wrote:
> - Readable "hence unspecified". In several other places, including InputStream.transferTo, we use "therefore unspecified" and it would be good to keep that consistent.
Mea culpa on the “hence.”
> - Readable "Depending on which class implements the appendable ...". What would you think about replacing this sentence with: "If the destination is capacity bounded and has insufficient capacity to append all characters read from the source then an exception will be thrown after transferring zero or some bytes to the destination".
s/zero or some/zero or more/
More information about the core-libs-dev