RFR: 8189102: All tools should support -?, -h and --help

Alan Bateman Alan.Bateman at oracle.com
Sat Nov 18 08:41:47 UTC 2017

On 17/11/2017 11:23, Lindenmaier, Goetz wrote:
> Hi,
> please review this change. I also filed a CSR for this:
> http://cr.openjdk.java.net/~goetz/wr17/8189102-helpMessage/webrev.02/
> Bug: https://bugs.openjdk.java.net/browse/JDK-8189102
> CSR: https://bugs.openjdk.java.net/browse/JDK-8191477
> See the webrev for a detailed description of the changes.
A question for Jon Gibbons: In JEP 293 the guideline is that tools 
should support `--help`. Do you think this should be expanded to include 
`-help`, and `-?` (and maybe `-h` where it make sense)?

As regards the webrev then the changes to the localized resources can be 
dropped. As Jon noted, we don't usually edit these directly as they are 
bulk updated/replaced by translation drops that usually happen late in 
each release.

It's not clear to me that it's wroth trying to update the JAXB, JAX-WS, 
and CORBA tools. One reason the corresponding tool modules are 
deprecated-for-removal and there is a draft JEP to remove them 
completely [1]. In addition, the JAXB ad JAX-WS tools are problematic to 
change as they are owned by upstream projects on the Java EE github - 
any changes to the code in these modules needs to coordinated to avoid 
having a fork here.


[1] http://openjdk.java.net/jeps/8189188

More information about the core-libs-dev mailing list