RFR: Here are some URLClassPath patches

Martin Buchholz martinrb at google.com
Mon Feb 26 23:10:49 UTC 2018

On Mon, Feb 26, 2018 at 3:06 PM, mandy chung <mandy.chung at oracle.com> wrote:

> 8198480: Improve ClassLoaders static init block
> http://cr.openjdk.java.net/~martin/webrevs/jdk/ClassLoaders-static/
> https://bugs.openjdk.java.net/browse/JDK-8198480
> Can you rename initialModuleName to mainModule as Alan suggests (also in
> the comment)?

It's the other way around - I renamed it from mainModuleName to
initialModuleName based on Alan's comment.  (and the code elsewhere
continues to be inconsistent on this)

More information about the core-libs-dev mailing list