RFR 4358774: Add null InputStream and OutputStream
brian.burkhalter at oracle.com
Thu Jan 4 23:42:08 UTC 2018
On Dec 11, 2017, at 12:52 PM, Brian Burkhalter <brian.burkhalter at oracle.com> wrote:
> On Dec 8, 2017, at 3:12 PM, Brian Burkhalter <brian.burkhalter at oracle.com> wrote:
>> All previous suggested changes have been made in
>> except for the possible change of name for the IS and OS nullStream() methods which awaits consensus.
> As long as we’re still at it, given java.util.stream.Stream then
> might not be a bad alternative.
Re-reading the discussion  of last year regarding , it seems that there was convergence on all points raised except the names of the new methods. The alternatives are:
A) InputStream.nullStream() and OutputStream.nullStream() as in the most recent version, webrev.03,
B) InputStream.nullInput() and OutputStream.nullOutput() as shown above, and
C) InputStream.nullInputStream() and OutputStream.nullOutputStream().
Does anyone have any more comments on this point? I would be inclined to choose option C.
More information about the core-libs-dev