RFR 8139206: Add InputStream readNBytes(int len)

Alan Bateman Alan.Bateman at oracle.com
Mon Jan 22 21:22:54 UTC 2018

On 22/01/2018 21:12, Brian Burkhalter wrote:
> I can change it. The reason I used that verbiage was to match that of 
> read(byte[]):
>  "The |read(b)| method for class |InputStream| has the same effect as:
>  read(b, 0, b.length)"
True but the equivalent in readAllBytes won't guarantee that readNBytes 
is called (which I think is what you were trying to do in the latest 


More information about the core-libs-dev mailing list