RFR: 8229773: Resolve permissions for code source URLs lazily

Alan Bateman Alan.Bateman at oracle.com
Thu Aug 15 19:21:48 UTC 2019

On 15/08/2019 16:22, Claes Redestad wrote:
> (adding back core-libs-dev)
> Hi Roger,
> seems easy enough to add a writeReplace:
> http://cr.openjdk.java.net/~redestad/8229773/webrev.02
This mostly looks good. In LazyCodeSourcePermissionCollection it think 
"initialize" should be renamed to "ensureAdded" as that more accurately 
describes what it does. Also the class description could do with a bit 
of word smiting to make it clear that permissions for a CodeSource are 
lazily added to the underlying permission collection.


More information about the core-libs-dev mailing list