RFR: 8229773: Resolve permissions for code source URLs lazily

Claes Redestad claes.redestad at oracle.com
Fri Aug 16 12:30:02 UTC 2019

On 2019-08-15 21:21, Alan Bateman wrote:
> On 15/08/2019 16:22, Claes Redestad wrote:
>> (adding back core-libs-dev)
>> Hi Roger,
>> seems easy enough to add a writeReplace:
>> http://cr.openjdk.java.net/~redestad/8229773/webrev.02
> This mostly looks good. In LazyCodeSourcePermissionCollection it think 
> "initialize" should be renamed to "ensureAdded" as that more accurately 
> describes what it does. Also the class description could do with a bit 
> of word smiting to make it clear that permissions for a CodeSource are 
> lazily added to the underlying permission collection.

How about this:


Also simplified BuiltinClassLoader#getPermissions since the jrt-specific
optimization is now redundant.


More information about the core-libs-dev mailing list