jpackage custom resources not found

Kustaa Nyholm kustaa.nyholm at
Mon Jan 14 10:27:35 UTC 2019


over the weekend I tried to use the EA jpackage from here:

I invoke it like this:


create-image \
--build-root build-jpackager \
--verbose \
--echo-mode \
--add-modules java.base,java.desktop \
--input /Users/nyholku/EazyCNC-Project/javapackager-resources \
--output . \
--name EazyCNC \
--main-jar EazyCNC.jar \
--class eazycnc.Main \

But I keep getting these messages:

Using default package resource [icon]  (add package/macosx/EazyCNC.icns to the class path to customize)
Preparing Info.plist: /Users/nyholku/EazyCNC-Project/./
Using default package resource [Application Info.plist]  (add package/macosx/Info.plist to the class path to customize)
Using default package resource [Java Runtime Info.plist]  (add package/macosx/Runtime-Info.plist to the class path to customize)

even though the resources exist (and worked with JDK8 javapackager):

ls /Users/nyholku/EazyCNC-Project/javapackager-resources/package/macosx/Info.plist

wbr Kusti

More information about the core-libs-dev mailing list