jpackage errors

Michael Hall mik3hall at
Sat Jan 19 14:28:26 UTC 2019

> On Jan 19, 2019, at 8:19 AM, Andy Herrick <andy.herrick at> wrote:
> 1.) jpackage is only compatible with JDK9+,  so it can't work with --runtime-image pointing to JDK8, but clearly I need some work to detect that and display a clear error message.

OK thanks. I did also try 9 and 11 the same way. I haven't used those yet much myself but the error related to the jli dylib was the same for each. 
When I was trying to figure out why my app was originally not working with 12 I found a jli.dylib in my MacOS directory and I think I tried moving it out. So it might be something I did?
But, for right now including the runtime option always fails on copying that file.

> 2.) javax.script.ScriptException is a public API so I don't see why you would get this NoClassDefFoundError, can you shar the entire jpackage build command ?

This was just missing an —add-modules I realized later. I haven’t done that much modular related so far. This error was easily fixed. I’m still not sure on the runtime error though that it accidentally turned up.

More information about the core-libs-dev mailing list