jpackage windows 32 bit jre

Kustaa Nyholm kustaa.nyholm at
Fri Jan 25 20:27:20 UTC 2019

Ok, thanks, I'm not expecting this sort of backward support, I have special
case were I need the 32 bit and figured since I had all the infrastructure
in place, what the heck, what have I got to lose ;)

I will dig up my old java8 build and use that for this, thanks again!

wbr Kusti

> On 25 Jan 2019, at 20.45, Andy Herrick <andy.herrick at> wrote:
> Packing JDK8 runtime, or packaging app with JDK8 runtime is not supported by jpackage.
> It is recommended to package JDK8 apps using the javafxpackager in JDK8.
> It is interesting you got this far.
> I tried this myself and get a 32 bit jre8 installed (by default in the wrong place, C:\Program Files\jre8 instead of C:\Program Files (x86)\jre8) but otherwise seems to work (I can run "javaws -viewer" from these to invoke the JCP)
>> jpackage create-jre-installer exe \
>> --input empty-dir \
>> --output output \
>> --name jre8 \
>> --runtime-image jre8 \
> /Andy
> On 1/25/2019 1:09 PM, Kustaa Nyholm wrote:
>> I tried and succeeded in using the jpackage from jdk13 (not really) to package 32 bit java8 for Windows.
>> Everything goes nicely at build time and when I double click the .exe an install is performed,
>> however the resulting installed .exe fails with "Failed to find library C:\Program Files\jDraft\runtime\bin\jli.dll"
>> But that file is there, though it is a bit suspicious that it is not in the Program Files(x86).
>> Should it be possible to embed 32 bit JRE or am I doomed to fail?
>> wbr Kusti

More information about the core-libs-dev mailing list