jpackage current status

Michael Hall mik3hall at
Fri Feb 21 17:04:44 UTC 2020

> On Feb 21, 2020, at 9:39 AM, Michael Hall <mik3hall at> wrote:
>> You can't copy launchers in this way as it requires the module to be in the run-time image.
> If I add modules it into the build runtime I think I’m ok but haven’t tried it yet.

jpackage seems to need more than just the module in the run-time image. 
I did the jpackage build again including it in the --add-modules

This now shows it there…

exec java --list-modules | grep jpackage at 14

However, I still get this…

exec jpackage --version Cannot run program "jpackage": error=2, No such file or directory
	at java.base/java.lang.ProcessBuilder.start(Unknown Source)
	at java.base/java.lang.ProcessBuilder.start(Unknown Source)

Running it directly now works…

./jpackage --version
WARNING: Using incubator modules: jdk.incubator.jpackage

Which I think again shows the module is included in the run-time image.

Possibly there is some other dependency. I’ll have to figure that out or wait until jpackage is out of incubator.

More information about the core-libs-dev mailing list