[Bug 798] New: Choppy Audio in Runescape

bugzilla-daemon at icedtea.classpath.org bugzilla-daemon at icedtea.classpath.org
Sun Oct 2 13:11:29 PDT 2011


           Summary: Choppy Audio in Runescape
           Product: IcedTea-Web
           Version: unspecified
          Platform: all
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P5
         Component: Plugin
        AssignedTo: dbhole at redhat.com
        ReportedBy: shiningarcanine at gmail.com
                CC: unassigned at icedtea.classpath.org

If you go to Runescape.com and click "Play Now", your browser will load a JOGL
Java-applet based game. If you are using Sun's nsplugin, then you should hear 
smooth audio. If you are using IcedTea, then you could hear choppy audio.

Six months ago, I reported a similar issue in bug #664 where no audio could be
heard in Runescape. Denis Lila closed that bug after fixing an issue in
JNLPClassLoader, which should have made things work, but there seems to be
another regression somewhere. The nsplugin included in the official JDK does not suffer from this issue.

I have encountered this issue on an amd64 Gentoo Linux system. It uses Linux
3.0.3, alsa-lib gcj-jdk 4.4.6, IcedTea6 1.10.3, IcedTea-Web 1.1.3 and
JOGL 1.1.1a. I have tried downgrading components to Linux, IcedTea6
1.10 and IcedTea-Web 1.1, but I cannot eliminate the issue. As a shot in the
dark, I tried both Google Chrome 15.0.874.54 beta and Firefox 7.0.1, but
neither resolved the issue.

Configure bugmail: http://icedtea.classpath.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

More information about the distro-pkg-dev mailing list