[RFC][icedtea-web]: PR1049 fix - extension jnlp with empty jars
adomurad at redhat.com
Wed Aug 1 12:12:29 PDT 2012
On Mon, 2012-07-23 at 18:47 -0400, Saad Mohammad wrote:
> Hi Adam,
> Sorry for multiple emails but it seems like the patch command does not like
> empty files too much :(. The previous patch was not creating the new empty file
> because it had no content
> I have fixed this problem in the updated reproducer patch attached. This patch
> contains two filename changes and an added test.
> I have attached the PRO1049 fix in my previous email with some comments. Please
> let me know if you run into any problems. Sorry again for all the trouble.
> 2012-07-23 Saad Mohammad <smohammad at redhat.com>
> * netx/net/sourceforge/jnlp/runtime/JNLPClassLoader.java (initializeResources):
> Removes the display of the security dialog for loaders with only empty jars.
> * netx/net/sourceforge/jnlp/tools/JarCertVerifier.java:
> (JarCertVerifier): Tracks whether all jars verified are empty jars.
> (hasAllEmptyJars): Returns true if all jars verified are empty jars.
> (verifyJars): Checks whether signable entries and certificates are found and
> decides if all jars are empty jars.
> (isFullySignedByASingleCert): If all jars are emptyJars, returns true.
> Launching jnlp with the resource of an empty jar and an extension jnlp
> containing the main jar.
> Launching jnlp with the resource of the main jar and an extension jnlp
> containing the empty jar.
> * tests/reproducers/signed/EmptySignedJar/resources/EmptySignedJarExtension.jnlp:
> Extension jnlp containing only an empty jar.
> * tests/reproducers/signed/EmptySignedJar/srcs/META-INF/emptyFile:
> Empty file within META-INF; required to create EmptySignedJar.jar
> by the test engine.
> * tests/reproducers/signed/EmptySignedJar/testcases/EmptySignedJarTest.java:
> Testcase that tests jnlp files with empty jars.
> * tests/reproducers/signed/SignedJarResource/resources/SignedJarResource.jnlp:
> Launches SignedJarResource class directly.
Hey, sorry for the lag. The tests look OK. The implementation is good,
its definitely better with the naming change.
One note, tests act like expected the pass/fail of
usingExtensionWithEmptyJar() depends on the accept/deny of a pop up. I'm
not sure what you could do about this. Otherwise all looks good for
More information about the distro-pkg-dev