FYI: armv5 tried to use the thumb2 JIT when passed -Xcomp

Xerxes Rånby xerxes at
Thu Jan 19 07:44:25 PST 2012

armv5 tried to use the thumb2 JIT when passed -Xcomp
This causes a lot of failures on the armv5 armel buildbot for all jtreg tests using the -Xcomp flag.
this patch fix:

I will push this patch to icedtea6 head and icedtea6-1.11 release branch.
Reviewed by aph on IRC.
(16.23.37) aph: xranby: OK, that’s obvious/trivial, good for trunk & branch

2012-01-19 Xerxes Rånby <xerxes at>
Andrew Haley <aph at>

* openjdk/hotspot/src/cpu/zero/vm/thumb2.cpp
(Thumb2_Compile): Disable T2-JIT on unsupported targets like armv5.

Index: icedtea6-1.11/arm_port/hotspot/src/cpu/zero/vm/thumb2.cpp
--- icedtea6-1.11.orig/arm_port/hotspot/src/cpu/zero/vm/thumb2.cpp 2012-01-18 15:34:56.000000000 +0100
+++ icedtea6-1.11/arm_port/hotspot/src/cpu/zero/vm/thumb2.cpp 2012-01-19 16:05:52.000000000 +0100
@@ -7055,6 +7055,9 @@
Thumb2_Entrypoint thumb_entry;
int compiled_accessor;

+ if (!(CPUInfo & ARCH_THUMBEE))
+ UseCompiler = false;
if (!UseCompiler || method->is_not_compilable()) {
ic->set(ic->state(), 1);
bc->set(ic->state(), 1);

More information about the distro-pkg-dev mailing list